Installing pyDARN


License: LGPL v3 Python 3.6 GitHub release (latest by date) DOI

Important

It is recommended to install pyDARN via pip; however, please cite via the DOI for the release

Prerequisites

pyDARN requires python 3.6 or later and matplotlib 3.3.4 or later.

Depending on your operating system or distribution, the following package installers, development environments or data parsers are required:

Ubuntu OpenSuse Fedora OSX Windows
libyaml-dev python3-PyYAML libyaml-devel Xcode/pip pip

You can check your python version using

$ python --version or $ python3 --version

Note

If you have already installed pydarn you can use pip3 install --upgrade pydarn

Dependencies

pyDARN's setup will download the following dependencies:

Note

If you wish to plot coastlines you will need to install cartopy>=0.19 separately

Cartopy

Cartopy is a Python package designed for geospatial data processing in order to produce maps and other geospatial data analyses. This library is used when invoking a projection system needing overlapped coastline maps in Fan, Grid and Map plots.

For installing cartopy please follow the packages installation instructions. For ubuntu here is good installation link

Warning

For cartopy to work with pyDARN please make sure it version >=0.19. Otherwise pydarn will throw an exception if you try to use it.

Note

cartopy is a challenging package to install so please provide any information on troubleshoot or solutions to common issue on pyDARN github page.

Virtual Environments

It is recommended to install pyDARN in one of the suggested virtual environments if you have multiple python/pip 3 version on your computer, or do not want to affect the main system's python libraries.

The following virtual environments have been tested by pyDARN developers:"

pip Virtual Environment

Instructions can be found here virtual environment

Option 1: 1. $ python3 -m pip install --user virtualenv (Install virtual environment package) 2. $ python3 -m virtualenv <environment name> (Make your virtual environment) 3. $ source <environment name>/bin/activate (Activate the virtual environment) 4. $ pip install pydarn (Install pyDARN)

Note

If you have multiple versions of python 3 on your machine, you can access a specific version by: python<version number>. For example, if you want to install python 3.6 virtual environment: python3.6 -m pip install --user virtualenv.

Anaconda Virtual Environment

Instructions can be found here conda environment and installing anaconda

  1. $ conda create -n yourenvname python=3.7 anaconda
  2. $ conda activate yourenvname
  3. $ pip install pydarn

Adding the environment to PyCharm

To set the project interpreter to the anaconda environment:

  1. File -> Settings -> Project Folder -> Project Interpreter
  2. Click the project Interpreter drop down list and click on show all.
  3. If you don't see the environment you wish to use click the plus sign on the right side bar named "Add"
  4. Select "Conda Environment" on the left side menu.
  5. Click "Existing Environment" and give the interpreter field the path to your environment's python.exe and apply.

Local Install

pip3 install

pip3 install --user pydarn

System Install

sudo pip3 install pydarn

Installing for Development

pyDARN's default github branch is develop for quicker and easer development.

It is encouraged to use SSH keys in GitHub

git clone git@github.com:SuperDARN/pydarn.git

To install:

$ pip3 install . --user

Note

If pip --version is pointing to python 3.6+ then you can use pip install . --user instead.

Note

Sometimes python setup.py install is needed to grab all hardware files (known issue).

Please read pyDARN Workflow documentation to further understand how to develop in pyDARN.

Troubleshooting

Pip3 installation with Ubuntu 20.4/python 3.8.4

Issue: pip3 install --user git+https://github.com/superdarn/pydarn@develop not working

Solution: 1. check git is installed apt install git (for ubuntu) 2. Check pip version pip --version - with newer distros of Linux/Virtual machines pip may point to pyhon3 and you will not need pip3. 3. Alternative virtual environment steps for getting python 3.8 working

$ sudo apt-get update
$ sudo apt-get install python3-virtualenv python3-pip
$ cd ~/
$ mkdir venvs
$ virtualenv -p python3.8 ~/venvs/py38
$ echo "source $HOME/venvs/py38/bin/activate" >> ~/.bashrc

Then open a new terminal and you should see (pyy38) in the prompt.

Credit to this solution is Ashton Reimer, more details on the issue #37

aacgmv2 won't install

Issue: unable to execute 'gcc': No such file or directory error: command 'gcc' failed with exit status 1

Solution: 1. Ensure gcc is installed if not install it 2. Ensure you install python3-dev (Ubuntu) or python3-devel for RPM OS Linux operating systems.

Credit to this solution is Marina Schmidt brought up by Remington Rohel from SuperDARN Canada

If you find any problems/solutions, please make a github issue so the community can help you or add it to the documentation

Summary plots get a ValueError

Issue: ValueError: Cannot convert 0 to a date. This often happens if non-datetime values are passed to an axis that expects datetime objects. when using plot_summary

Solution: 1. check matplotlib version, if lower than 3.3.4 then upgrade matplotlib equal or higher version.
2. pip install -U matplotlib